Re: “Bad Major Version” Error

I’ve attached a txt file with the stack trace here.

 

Setting the compiler compliance to an older version is not the issue (if I set it to 1.6 the project does not build as I get errors like:

 
‘<>‘ operator is not allowed for source level below 1.7

 

From what I can tell, the code was compiled with JDK 1.7. The bad version would occur if I were trying to run it with (for example 1.6, which is the default for 3.8). The question is whether I can tell DOC3.8 to deploy based on 1.7

 

Source: Re: “Bad Major Version” Error